The search request was unable to connect to the Search Service

The wonderfull world of MOSS Error Messages.

If you try a search in your portal and receive the following message and no error message in your eventLog:

The search request was unable to connect to the Search Service

Try this resolution:

- Go to Central Administration

- Operations Tab

- Services on Server

- Office Share Point Server Search

- check if the following option is enabled Use this server for serving search queries

 

Another possible resolution could be that the user who is configured to run the search has not the required permissions. So check the user permission on the SQL Database. And if your SQL Server is running under Mixed Mode Authentication.

If this does not work, please let me know i will try to help you!

 greets

nadine 


Posted Mar 11 2008, 02:02 PM by Nadine Storandt
Filed under: , ,

Comments

Upen Nathwani wrote re: The search request was unable to connect to the Search Service
on 09-17-2008 12:18

Hi I have installed WSS 3.0 after MOSS 2007 and getiing following error "The search request was unable to connect to the Search Service"

Also searching is working using MOSS search.asmx reference but its not working in case of SPSearch.asmx reference that is of WSS 3.0

Thanks

Upen

Nadine Storandt wrote re: The search request was unable to connect to the Search Service
on 09-17-2008 18:01

Hey Upen,

that is correct how it works. Because the SPSearch.asmx will only work in a clean WSS 3.0 Enviroment. if you have installed MOSS 2007 and WSS 3.0 you have to use the Search.asmx reference.

here are 2 links which describes the problem:

www.experts-exchange.com/.../Q_23487933.html

msdnrss.thecoderblogs.com/.../spsearchasmx-web-service-will-not-return-any-results-in-the-search-server-2008-integrated-wss-30-environment

hope it helps u.

greets

nadine

Cris wrote re: The search request was unable to connect to the Search Service
on 10-28-2008 19:23

Thanks Nadine,

your solution and a quick guess helped me fix this issue.  We are a single server farm in My Central admin I also had to check Use this server for serving search queries.  Also remember to run iisreste /noforce after nearly every SharePoint change.

Thanks

Chris wrote re: The search request was unable to connect to the Search Service
on 01-18-2010 15:26

Hello Nadine,

i have the same problem like you discribed.

Every time i use the search i'll get  "The search request was unable to connect to the Search Service".

- Indexing service is Installed on the servers.

- Search services are running with user that has nessesary permissions.

- Index was reseted and rebuilded for all content sources.

- Office server search service in CA was stoped and started.

- Servers where restarted.

- Service is running with not build in account.

- Mixed mode in SQL server is on.

- No errors in eventlog.

what can i do to get any results by using the search?

greets

chris

Nachiket wrote re: The search request was unable to connect to the Search Service
on 09-21-2010 8:00

I am facing the same issue and was trying to follow the steps you have mentioned in the begining but I am unable to find Office Share Point Server Search after I click Services on server tab.

OPlease help me out with it.

Chaitanya wrote re: The search request was unable to connect to the Search Service
on 06-02-2011 9:28

Hi When i am trying to searcg for a document on share point serverv i am getting an error message as " The search request was unable to connect to the

Search Service" Can some one pls help me how to resolve it...

Thanks in advance

Chaitanya

Add a Comment

(required)  
(optional)
(required)  
Remember Me?
developers.de is a .Net Community Blog powered by daenet GmbH.